Friday, February 29, 2008

Wildrose Alliance Endorses HRCs!

Lost in yesterday's "Daily Nazi" post was a mildly interesting tid-bit. John Murdoch, campaign chair of Alberta's Wildrose Alliance, which is polling at about 7 per cent and might just maybe possibly win a seat in next week's provincial election, has endorsed the existence of Human Rights Commissions:

Further to this, whomever was saying we do not support Human rights commissions is obviously speaking out of turn as there is no such policy and certainly no such prevailing sentiment in the party.

Obviously trying to take a few steps towards the mainstream.

Yo Mark, Ezra...suck on that, Speechy boyzz! You can't even count on The Alliance! Not even Alberta's Conservative fringe! Boo-yah! Boo-yah! Your revolution is down the toilet! Boo-yah!

4 comments:

Anonymous said...

Are these idiotic comments what passes for debate nowadays?

Ti-Guy said...

Are you offering an alternative?

Anonymous said...

So let's see. If you support the HRC, you're just like the neo-Nazi party. And if you don't support the HRC, then you are a nazi. Have I got that right?

Ti-Guy said...

So let's see. If you support the HRC, you're just like the neo-Nazi party. And if you don't support the HRC, then you are a nazi. Have I got that right?

I sympathise with your incomprehension. I've never been able to discern any great degree of coherence when it comes to rightwingers.

Oh, hang on...You think it's up to liberals to explain it all to you?

Well, I think it all comes down to practically no one on the Right wanting to be openly associated with fascism. But frankly, as far as I'm concerned, that's something righties need to work out for themselves. If they ever decide to turn their attention to having that kind of critical discussion among themselves and away from confronting liberals, progressives and lefties with their ignorant attacks, that might be possible.

I wish them good luck. With that collection of third-tier minds that currently make up the Right, they're going to need it.